Snyk Container - Supported operating system distributions
Snyk Container supports the following operating system distributions.
If you use an unsupported distribution, such as one which has reached its End-of-life (EOL) and is no longer being maintained, Snyk provides a message to tell you this is unsupported.
For unsupported distributions, you may not receive any notifications of vulnerabilities due to a lack of security updates: this does not mean that your image is secure.

  • Alpine Linux 3.16
  • Alpine Linux 3.15
  • Alpine Linux 3.14
  • Alpine Linux 3.13
  • Alpine Linux 3.12
  • Alpine Linux 3.11
  • Alpine Linux 3.10
  • Alpine Linux 3.9
  • Alpine Linux 3.8
  • Alpine Linux 3.7
  • Alpine Linux 3.6
  • Alpine Linux 3.5
  • Alpine Linux 3.4
  • Alpine Linux 3.3
  • Alpine Linux 3.2

  • Amazon Linux 2022
  • Amazon Linux 2
  • Amazon AMI 2018.03

  • CentOS Stream 9
  • CentOS Stream 8

  • CentOS Linux 8
  • CentOS Linux 7
  • CentOS Linux 6

  • Unstable
  • Debian 12
  • Debian 11
  • Debian 10
  • Debian 9
  • Debian 8

  • Oracle Linux 9
  • Oracle Linux 8
  • Oracle Linux 7
  • Oracle Linux 6
  • Oracle Linux 5

  • Red Hat Enterprise Linux 9
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 6

  • SUSE Linux Enterprise Server 15.2
  • SUSE Linux Enterprise Server 15.1
  • SUSE Linux Enterprise Server 15.0

  • Ubuntu 21.10
  • Ubuntu 21.04
  • Ubuntu 20.10
  • Ubuntu 20.04
  • Ubuntu 19.10
  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04
  • Ubuntu 17.10
  • Ubuntu 17.04
  • Ubuntu 16.10
  • Ubuntu 16.04
  • Ubuntu 15.10
  • Ubuntu 15.04
  • Ubuntu 14.10
  • Ubuntu 13.10
  • Ubuntu 13.04
  • Ubuntu 12.10
Export as PDF
Copy link
Edit on GitHub
On this page
Supported Linux distributions
Alpine Linux
Amazon Linux
CentOS Stream
CentOS Linux
Debian
Oracle Linux
Red Hat Enterprise Linux (RHEL)
SUSE Linux Enterprise Server (SLES)
Ubuntu