Supported operating system distributions
Snyk Container supports the following operating system distributions.
If you use an unsupported distribution, such as one which has reached its End of life (EOL) and is no longer being maintained, Snyk provides a message to tell you this is unsupported.
For unsupported distributions, you may not receive any notifications of vulnerabilities due to a lack of security updates: this does not mean that your image is secure.

Supported linux distributions

Alpine Linux

    Alpine 3.14
    Alpine 3.13
    Alpine 3.12
    Alpine 3.11
    Alpine 3.10
    End of Life:
    Alpine 3.9
    Alpine 3.8
    Alpine 3.7
    Alpine 3.6
    Alpine 3.5
    Alpine 3.4
    Alpine 3.3
    Alpine 3.2
    Alpine 3.1
    Alpine 3.0
    Alpine 2.7
    Alpine 2.6

Amazon Linux

    Amazon Linux 2
    Amazon AMI 2018.03

CentOS

    CentOS 8
    CentOS 7
    CentOS 6
    End of Life:
    CentOS 5

Debian

    Debian 12
    Debian 11
    Debian 10
    Debian 9
    End of Life:
    Debian 8
    Debian 7
    Debian 6

Oracle Linux

    Oracle 8
    Oracle 7
    Oracle 6
    End of Life:
    Oracle 5
    Oracle 4
    Oracle 3

Red Hat Enterprise Linux

    RHEL 8
    RHEL 7
    RHEL 6
    End of Life:
    RHEL 5

Ubuntu

    Ubuntu 21.10
    Ubuntu 21.04
    Ubuntu 20.10
    Ubuntu 20.04
    Ubuntu 18.10
    Ubuntu 18.04
    Ubuntu 16.04
    End of Life
    Ubuntu 19.10
    Ubuntu 19.04
    Ubuntu 17.10
    Ubuntu 17.04
    Ubuntu 16.10
    Ubuntu 15.10
    Ubuntu 15.04
    Ubuntu 14.10
    Ubuntu 13.10
    Ubuntu 13.04
    Ubuntu 12.10
    Ubuntu 12.04
    Ubuntu 11.10
    Ubuntu 11.04
    Ubuntu 10.10
    Ubuntu 10.04
    Ubuntu 9.10
    Ubuntu 9.04
    Ubuntu 8.10
    Ubuntu 8.04
    Ubuntu 7.10
    Ubuntu 7.04
    Ubuntu 6.10
    Ubuntu 6.06
    Ubuntu 5.10
    Ubuntu 5.04
    Ubuntu 4.10

Beta support

The following operating system distributions are currently available as beta. If you use a beta distribution, Snyk provides you a message to notify you.
For beta distributions, vulnerability detection may be affected while we keep on improving the data.

SUSE Linux Enterprise Server

    SLES 15.2
    SLES 15.1
    SLES 15.0
    SLES 12.5
    SLES 12.4
    SLES 12.3
    SLES 12.2
    SLES 12.1
    SLES 12.0
    SLES 11.4
    SLES 11.3
    SLES 11.2
    SLES 11.1
    SLES 11.0
Last modified 6d ago